Архив метки: 1c

Именованный массив в 1С

Ну собственно его нет в 1с. Есть некий «аналог», понятие «Структура».

Инициализируется например вот так:

ОтчетСтруктура=Новый Структура;
ОтчетСтруктура.Вставить("НаТранспорте",0);

Причем ключ не должен содержать пробелов и цифр в начале.

К проинициализированной структуре можно обращаться по ключу например так:

ОтчетСтруктура["НаТранспорте"]=ОтчетСтруктура["НаТранспорте"]+1;

Проверка наличия ключа осуществляется так:

если ОтчетСтруктура.Свойство("ключ") тогда
конецесли

Но я в своей практике, немножко по другому поступил, когда мне была не известна заведомо структура:

&НаСервере
Функция ЗаменитьПробелы(_стр)
	стр=СтрЗаменить(_стр, " ", "_");
Возврат стр;
КонецФункции

// цикл 1, заполняем структуру

		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл				
			если ВыборкаДетальныеЗаписи.Другое<>"" тогда				
				ОтчетСтруктура.Вставить(ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое),0);
			конецесли;	
конеццикла;		


// цикл 2, приращиваем счетчики
		ВыборкаДетальныеЗаписи = Результат.Выбрать();			
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
если ВыборкаДетальныеЗаписи.Другое<>"" тогда							
					ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]=ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]+1;
			конецесли;								
			
		конеццикла;

 

Изменяем функционал документа 1С без изменения конфигурации (Расширением)

В очередной раз понадобилась доработка одного из документов 1С, а именно, чтобы при проведении документа, выводилось некое модальное окно, с вопросами менеджеру который этот документ проводит. А так как я противник какого либо изменения стандартной конфигурации (кушано достаточно с обновлениями) не по делу, то решил попробовать вариант с «расширениями».

Итак, сначала создаем регистр сведений, куда собственно будем заносить информацию которую будет заполнять менеджер. Привязка — к документу реализации:

Далее создадим расширение, через меню Конфигруация — Расширения конфигурации:

Переносим форму документа «Реализация товаров» в раширения:

В появившемся редакторе расширений, видим форму, с не заполненными действиями в командах формы. Если мы попробуем создать действие, выведется вопрос:

, когда вызывать данное действие, ДО, ПОСЛЕ ил ВМЕСТО. В моем случае, я выбрал ДО, и вписал в обработчик следующий код:

&НаКлиенте
Процедура Расш1_ПровестиИзФормыПеред(Команда)
	Структура = Новый Структура("Документ", Объект.Ссылка);
	Массив = Новый Массив;
	Массив.Добавить(Структура);
	Ключ = Новый("РегистрСведенийКлючЗаписи.ДопИнформациОПродажеГрибов", Массив); 
	ПараметрыФормы = Новый Структура("Ключ", Ключ);
	попытка
		ОткрытьФорму("РегистрСведений.ДопИнформациОПродажеГрибов.ФормаЗаписи", ПараметрыФормы);	
	исключение
		Форма = ПолучитьФорму("РегистрСведений.ДопИнформациОПродажеГрибов.ФормаЗаписи");
		Форма.Запись.Документ = Объект.Ссылка;
		Форма.Открыть();	
	конецпопытки
КонецПроцедуры

При нажатии кнопки «Провести» теперь выскакивает окно:

Ну и соответственно пишет в регистр информацию для размышления:

1С: «Ограничение прав доступа» при удаление объекта справочника

Долго сегодня пришлось искать, почему пользователь с обычными правами не может удалить запись из справочника, который никак и ни с чем не связан. Наконец догадался глянуть в журнал регистрации:

После того как дал права на этот регистр, всё заработало…

1С: файл не обнаружен AppAutoCheckMode

Ну собственно эта ошибка стала выводиться при запуске приложения «с ярлычка» пользователя, где прописан пусть для жесткого выбора базы данных, после последнего обновления.

Было:

"C:\Program Files (x86)\1cv8\common\1cestart.exe" /Slocalhost\roznica /ENTERPRISE

Стало:

"C:\Program Files (x86)\1cv8\common\1cestart.exe" ENTERPRISE /Slocalhost\roznica

Программная проверка пользователя 1С

Есть тысяча способов ограничить пользователя в 1С. Самый простой, если часть кода самописная, это «жесткая» привязка к конкретным пользователям. Например это можно сделать так:

&НаСервере
Функция ПроверитьПользователя(пользователь)
	рез=ложь;
	если пользователь=ПользователиИнформационнойБазы.ТекущийПользователь().Имя тогда
		рез=Истина;
	конецесли;		
	возврат рез;
конецфункции

&НаКлиенте
Процедура Моржа(Команда)	
	если ПроверитьПользователя("Администратор")=истина или ПроверитьПользователя("Помидоров")=истина или ПроверитьПользователя("Сантаклаусов")=истина тогда
	Форма=ПолучитьФорму("Обработка.ОтчетПоМоржеНовыйГрибов.Форма");	
		ДанныеФормы=Форма.Объект;
		//ДанныеФормы=РеализацияТовараНаСервере(ДанныеФормы);
		КопироватьДанныеФормы(ДанныеФормы,Форма.Объект);
	Форма.Открыть();
	иначе
		сообщить("Вам это не нужно..");
	конецесли;
КонецПроцедуры