1C: Еще один вариант вывода данных с пагинацией

На этот раз, данные подготовлены для JSON JqGrid. Рабочий вариант для не большого количества записей (около 1000). В противном случае будут «тормоза» в 1С, т.к. листается вся выборка для построения «страницы».

Функция GetListing(body, answer) Экспорт	
	answer.result = Новый Массив;
	answer.error = Истина;
	answer.errortext = "Ошибка!";		
		Если body.Свойство("page") Тогда
			page = Число(body.page);
		Иначе
			page = 1;
		КонецЕсли;
		
		Если body.Свойство("limit") Тогда
			limit = Число(body.limit);
		Иначе
			limit = 20;
		КонецЕсли;
		
		Если body.Свойство("sidx") Тогда
			sidx = body.sidx;
		Иначе
			sidx = "";
		КонецЕсли;
		
		Если body.Свойство("sord") Тогда
			sord = body.sord;
		Иначе
			sord = "";
		КонецЕсли;
		
		Если body.Свойство("flt") Тогда
			flt = body.flt;
		Иначе
			flt = Неопределено;
		КонецЕсли;			
			
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ХрюХрю.Номер КАК id,
		|	ХрюХрю.НачалоЧесания КАК dtstart,
		|	ХрюХрю.ДлительностьПочесывания КАК long,
		|	ХрюХрю.Пятачок.Наименование КАК column,
		|	ХрюХрю.ВыходПятачка.OCPP_num КАК outlet,
		|	ХрюХрю.НачальныеПоказанияСчастья КАК meterstart,
		|	ХрюХрю.КонечныеПоказанияСчастья КАК meterend,
		|	ПРЕДСТАВЛЕНИЕ(ХрюХрю.ТекущийСтатусПочесывания) КАК status,
		|	ХрюХрю.ТекущийСтатусПочесывания КАК ТекущийСтатусПочесывания
		|ПОМЕСТИТЬ тЗарядки
		|ИЗ
		|	Документ.ХрюХрю КАК ХрюХрю
		|ГДЕ
		|	ХрюХрю.ЭЗС.Владелец.Код = &Код
		|	И ХрюХрю.ПометкаУдаления = ЛОЖЬ
		|	И ХрюХрю.НачалоЧесания МЕЖДУ &ДатаНачала И &ДатаКонца
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	тЗарядки.column КАК column,
		|	тЗарядки.dtstart КАК dtstart,
		|	тЗарядки.id КАК id,
		|	тЗарядки.long КАК long,
		|	тЗарядки.meterend КАК meterend,
		|	тЗарядки.meterstart КАК meterstart,
		|	тЗарядки.outlet КАК outlet,
		|	тЗарядки.status КАК status,
		|	тЗарядки.ТекущийСтатусПочесывания КАК ТекущийСтатусПочесывания
		|ИЗ
		|	тЗарядки КАК тЗарядки
		|	&Фильтры
		|	&Сортировка	";
	Запрос.УстановитьПараметр("Код", пп.Владелец.Код);
	Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(Дата(body.datefrom)));
	Запрос.УстановитьПараметр("ДатаКонца", КонецДня(Дата(body.datefrom)));		
	
		Сортировка = "";
		Если ЗначениеЗаполнено(sidx) Тогда
				Сортировка = "УПОРЯДОЧИТЬ ПО " + sidx + " " + sord + ", id desc";
		КонецЕсли;
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "&Сортировка", Сортировка);
		
		Условие = "";
		status="";
		Если ЗначениеЗаполнено(flt) Тогда
			groupOp = flt.groupOp;
			rules = flt.rules;
			Для Каждого rule Из rules Цикл			
				Если rule.op = "bw" Тогда
					ЧастичноеУсловие = "(" + rule.field + " ПОДОБНО ""%" + rule.data + "%"")";
					Условие = Условие + ?(ЗначениеЗаполнено(Условие), " " + groupOp + " ", "") + ЧастичноеУсловие;					
				конецесли;
				Если rule.op = "eq" Тогда
					если rule.data<>"-1" тогда
						Если rule.field = "status" Тогда
							ЧастичноеУсловие = "(ТекущийСтатусПочесывания = &status)";
							status=rule.data;
						иначе
							ЧастичноеУсловие = "(" + rule.field + " = """ + rule.data + """)";
						конецесли;							
						Условие = Условие + ?(ЗначениеЗаполнено(Условие), " " + groupOp + " ", "") + ЧастичноеУсловие;
					конецесли;
				конецесли;
				
			конеццикла;				
			Если ЗначениеЗаполнено(Условие) Тогда
				Условие = "ГДЕ " + Условие;
			КонецЕсли;
		конецесли;		
	
	Запрос.Текст = СтрЗаменить(Запрос.Текст, "&Фильтры", Условие);
	если status<>"" тогда
		status=перечисления.СтатусыПочесывания[status];
		Запрос.УстановитьПараметр("status", status);
	конецесли;			
	
	РезультатЗапроса = Запрос.Выполнить();	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
	rows = Новый Массив();
	РезультатЗапроса = Запрос.Выполнить().Выгрузить(); // нехорошо

		колстрок = РезультатЗапроса.Количество();
		total = Цел((колстрок - 1) / limit) + 1;		
		rowid = (page - 1) * limit;
		lastrow = rowid + limit - 1;
		records=0;
		Пока rowid <= lastrow И rowid < колстрок Цикл
			Стр = РезультатЗапроса[rowid];
			cell = Новый Массив;
			cell.Добавить(Стр.id);
			cell.Добавить(Стр.dtstart);
			cell.Добавить(Стр.long);
			cell.Добавить(Стр.column);
			cell.Добавить(Стр.outlet);
			cell.Добавить(Стр.status);
			cell.Добавить(Стр.meterend-Стр.meterend);
			cell.Добавить(0);
			row = Новый Структура("id, cell", Стр.id, cell);
			rows.Добавить(row);
			rowid = rowid + 1;
			records=records+1;
		КонецЦикла;
		
		result = Новый Структура("page, total, records, rows", page, total, records, rows); 		
		
	answer.result = result;	
	answer.errortext="";
	answer.error = ложь;
	
	возврат answer;
конецфункции	

Ошибка отлова исключения в PHP 7.0+

Столкнулся с интересной ошибкой сегодня. Есть вызов функции. Есть обертка try — catch в ней, а она не срабатывает! Гуглил. Долго думал.. Оказывается в PHP 7.0 и выше, изменилось дерево наследования ошибок на:

Throwable
  Error
    ArithmeticError
      DivisionByZeroError
    AssertionError
    CompileError
      ParseError
    TypeError
      ArgumentCountError
  Exception

Соответственно «всех выше теперь» — Throwable, и если хочется теперь словить «глобальную» ошибку, то блок вызывать нужно:

try {

} catch(\Throwable $e) {

}

1С: Не выполняются регламентные задания

У платформы 1С в регламентных заданиях есть одна фишечка, на которую уже не первый раз попадаюсь. А именно, при создании регламентного задания в конфигураторе, его расписание в приложение «улетает» только один раз. А далее, это расписание хоть завыставляйся  в конфигураторе — выполняться оно будет по расписанию выставленному в приложении.

Следовательно алгоритм следующий: создали регламентное задание , задали расписание. Если нужно изменить расписание — идем в приложение и выставляем его там, в «Обработка.РегламентныеИФоновыеЗадания»

1С: Пять способов вывода сообщений с «сервера»

Конфигурации, платформы и БСП разные бывают, потому где-то сработает одно, где-то другое.

1) Универсальный способ: 

сообщить("Текст сообщения")

2)  Через СообщениеПользователю:

		    Сообщение = Новый СообщениеПользователю();
		    Сообщение.Текст = "Вид начисления "+стр.ВидНачисления+" в таблице 'Расчет ОДН' не соответствует виду услуги "+ВидУслуги;
		   Сообщение.Поле = "ДанныеДляНачиселенийПоОДН[0].ВидНачисления";
			Сообщение.ПутьКДанным = "Объект";
            Сообщение.КлючДанных = Ссылка;
		    Сообщение.Сообщить();

3) Старые БСП (ниже 3-й версии):

ОбщегоНазначения.Сообщение(Сообщение.Текст,, "Объект.ДанныеДляНачиселенийПоОДН",,);

4) Свежие БСП (выше 3 версии)

ОбщегоНазначения.СообщитьПользователю(ТекстСообщения,, "Объект.Товары",, Отказ);

5) Через «ВызватьИсключение»

Может быть полезно например при отказе в проведении документа в процедуре ОбработкаПроведения:

Процедура ОбработкаПроведения(Отказ, Режим)
блабла..
блабла...
проверки..

Отказ=истина;
ВызватьИсключение(Сообщение.Текст);

Как постранично (порционно) листать результат запроса в 1С (ака LIMIT x,y в MySQL)

Большая беда MSSQL и как следствие 1С — отсутствие возможности порционно листать записи результата запроса как в MySQL. В результате рождаются такие монстроузные алгоритмы как ниже (код не мой):

Функция GetNewsList(body, answer) Экспорт
	
	answer.error = Истина;
	answer.errortext = "Что-то пошло не так..";
	answer.result = "";
	
	Попытка
		page = ?(ЗначениеЗаполнено(body.page), Число(body.page), 1);
		Если page < 1 Тогда
			page = 1;
		КонецЕсли;
		
		nums = ?(ЗначениеЗаполнено(body.nums), Число(body.nums), 5);
		Если nums < 5 Тогда
			nums = 5;
		КонецЕсли;
		
		ПредДата = ТекущаяДата();
		ПредКод = "";
		Если page > 1 Тогда
			Запрос = Новый Запрос;
			Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 100
			               |	Хрюкости.Дата КАК Дата,
			               |	Хрюкости.Код КАК Код
			               |ПОМЕСТИТЬ тПредыдущих
			               |ИЗ
			               |	Справочник.ПоследниеСплетни КАК Хрюкости
			               |
			               |УПОРЯДОЧИТЬ ПО
			               |	Хрюкости.Дата УБЫВ,
			               |	Хрюкости.Код УБЫВ
			               |;
			               |
			               |////////////////////////////////////////////////////////////////////////////////
			               |ВЫБРАТЬ ПЕРВЫЕ 1
			               |	тПредыдущих.Дата КАК Дата,
			               |	тПредыдущих.Код КАК Код
			               |ИЗ
			               |	тПредыдущих КАК тПредыдущих
			               |
			               |УПОРЯДОЧИТЬ ПО
			               |	тПредыдущих.Дата,
			               |	тПредыдущих.Код";
			Запрос.Текст = СтрЗаменить(Запрос.Текст, "100", Формат((page - 1) * nums, "ЧДЦ=0; ЧН=; ЧГ="));
			Выборка = Запрос.Выполнить().Выбрать();
			Если Выборка.Следующий() Тогда
				ПредДата = Выборка.Дата;
				ПредКод = Выборка.Код;
			КонецЕсли;
		КонецЕсли;
		
		Запрос = Новый Запрос;
		Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 100
		               |	Хрюкости.Код КАК news_code,
		               |	Хрюкости.Дата КАК date,
		               |	Хрюкости.Наименование КАК name,
		               |	Хрюкости.Содержание КОНЕЦ КАК content,
		               |	Хрюкости.Изображение КАК image
		               |ИЗ
		               |	Справочник.ПоследниеСплетни КАК Хрюкости
		               |ГДЕ
		               |	(Хрюкости.Дата < &ПредДата)
		               |	ИЛИ
					   |	(Хрюкости.Дата = &ПредДата И Хрюкости.Код < &ПредКод)
		               |
		               |УПОРЯДОЧИТЬ ПО
		               |	Хрюкости.Дата УБЫВ,
		               |	Хрюкости.Код УБЫВ";
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "100", Формат(nums, "ЧДЦ=0; ЧН=; ЧГ="));
		Запрос.УстановитьПараметр("ПредДата", ПредДата);
		Запрос.УстановитьПараметр("ПредКод", ПредКод);
		Выборка = Запрос.Выполнить().Выбрать();
		
		РезМассив = Новый Массив;
		Пока Выборка.Следующий() Цикл
			РезСтрукт = Новый Структура("news_code, date, datestr, name, content, image");
			ЗаполнитьЗначенияСвойств(РезСтрукт, Выборка);
			РезСтрукт.datestr = Формат(Выборка.date, "ДФ='dd.MM.yyyy HH:mm:ss'");
			РезМассив.Добавить(РезСтрукт);
		КонецЦикла;
		
		ЕстьЕще = Ложь;
		Если РезМассив.Количество() > 0 Тогда
			КрайняяНовость = РезМассив[РезМассив.Количество() - 1];
			Запрос = Новый Запрос;
			Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
			               |	Хрюкости.Код КАК news_code
			               |ИЗ
			               |	Справочник.ПоследниеСплетни КАК Хрюкости
			               |ГДЕ
			               |	(Хрюкости.Дата < &ПредДата)
			               |	ИЛИ
						   |	(Хрюкости.Дата = &ПредДата И Хрюкости.Код < &ПредКод)
			               |
			               |УПОРЯДОЧИТЬ ПО
			               |	Хрюкости.Дата УБЫВ,
			               |	Хрюкости.Код УБЫВ";
			Запрос.УстановитьПараметр("ПредДата", КрайняяНовость.date);
			Запрос.УстановитьПараметр("ПредКод", КрайняяНовость.news_code);
			ЕстьЕще = НЕ Запрос.Выполнить().Пустой();
		КонецЕсли;
		
		answer.result = Новый Структура("portion, havingmore", РезМассив, ЕстьЕще);
		answer.error = Ложь;
		answer.errortext = "";
		
	Исключение
		answer.errortext = ОписаниеОшибки();
	КонецПопытки;
	
	Возврат answer;
	
КонецФункции

Если вкратце, то алгоритм следующий:

  1.  Делаем выборку ВСЕХ записей, определяя, с какой записи было начало предыдущей страницы
  2. Начиная с этой записи, делаем выборку N записей
  3. Передаем результат

Интересно будет посмотреть как этот алгоритм будет вести себя при миллионах записей..

 

Жизнь замечательных грибов