Архив метки: форма

Передача параметров при создании Формы.

Задача: по нажатии кнопки, открыть форму обработки с заполненным реквизитом ИНН.

Собственно вот классический способ:  по нажатию кнопки выполняем код:

&НаКлиенте
Процедура Расш1_ДействияБиллингаПосле(Команда)
	ПП = Новый Структура("ИНН", "100");
	Форма=ПолучитьФорму("Обработка.ДействияLanBilling.Форма.Форма",ПП);
	Форма.Открыть() 	
КонецПроцедуры

Далее обрабатываем параметр в самой форме, в процедуре ПриСозданииНаСервере:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Если Параметры.Свойство("ИНН") Тогда
        объект.ИНН=Параметры["ИНН"];
    КонецЕсли;	
КонецПроцедуры