Архив метки: 1с

1С — подчиненные таблицы на форме

83aca92d8bcb7c61deb9b267a914add6Для того чтобы связать на форме 2 таблицы, по принципу главная-подчиненная, необходимо вставить обработку выбора строки главной таблицы.

Процедура ПотребностиПриАктивизацииСтроки(Элемент)
	// Вставить содержимое обработчика.
	Если ЭлементыФормы.Потребности.ТекущаяСтрока <> Неопределено Тогда
  		ЭлементыФормы.СкладыУчета.ОтборСтрок.Номенклатура.Значение= ЭлементыФормы.Потребности.ТекущаяСтрока.Номенклатура;
  		ЭлементыФормы.СкладыУчета.ОтборСтрок.Номенклатура.Использование= Истина;
	КонецЕсли;

КонецПроцедуры

Остатки на складах с поставщиками УПП 8.2

Отчет формирует файл EXCEL с остатками на текущий день в разрезе складов, серий,номенклатуры, поставщикам. Поле поставщик заполняется по возможности, на основании документов поступления товаров и услуг (на самом деле нормально будет подставлять только в случае оприходования по сериям, иначе — последний поставщик).
Область применения: конкретно у меня — для отдела снабжения. Чтоб не давать всем доступ в 1С (отпадает проблема обучения, закрытия «лишнего» чтоб не «лазали» и т.п.). У меня данная обработка повешана в регламентные задания, и файл формируется каждый час.

Загрузить можно Здесь

Регламентные задания в 1С 8.2, файловый вариант

1. В общих модулях создаем процедуру, которая будет выполнятся по расписанию, которое мы назначим позже.
2. Создаем регламентное задание

3. Настраиваем расписание

4. В модуль управляемого приложения добавляем:

Процедура ПроверкаЗаданий()  Экспорт
    ВыполнитьОбработкуЗаданий();
КонецПроцедуры

ПодключитьОбработчикОжидания("ПроверкаЗаданий",3);

 

Генерация qr кода с помощью api google + ITF14 при помощи «1С печать штрихкодов»

По рабочему вопросу понадобилась печать стикера с QR 2Д и ITF-14 кодом. Сторонние решения для 1С не устраивали своей жадностью, а бесплатных решений кроме вот этого найдено не было. Очень помогла в разработке публикация http://infostart.ru/public/80106/ Скачать измененную версию можно здесь: http://infostart.ru/public/147843/ Читать далее Генерация qr кода с помощью api google + ITF14 при помощи «1С печать штрихкодов»

Справка А и Б

Почему то как всегда проморгали изменения законодательства, а потому изменение печатной формы документа пришлось делать буквально «вчера» )). Итог:Справка А и Б для отгрузки алкогольной продукции, утвержденная постановлением Правительства Российской Федерации от 31 декабря 2005 г. № 864 в редакции Постановления Правительства РФ от 02.05.2012 № 422.

Работает с УПП 8.2 с установленым модулем КТ-2000 алкоголь.

Скачать и обсуждение здесь