1С сортировка структуры

Хотя в синтаксисе обьекта структуры в 1С нет функции сортировки, тем не менее иногда просто необходимо иметь остортированную структуру. Поможет следующая функция:

&НаСервере
Функция сортировкаструктуры(ОтчетСтруктура)
			//сортировка структуры
		ТЗ = Новый ТаблицаЗначений;
	    ТЗ.Колонки.Добавить("Ключ");
	    ТЗ.Колонки.Добавить("Значение");
	    Для каждого элемент из ОтчетСтруктура Цикл
	        новСтрока = ТЗ.Добавить();
	        новСтрока.Ключ = Элемент.Ключ;
	        новСтрока.Значение = Элемент.Значение;
	    КонецЦикла;
	    ТЗ.Сортировать("Значение Убыв");
	    ОтчетСтруктура.Очистить();
	    Для каждого строкаТЗ из ТЗ Цикл
	        ОтчетСтруктура.Вставить(строкаТЗ.Ключ,строкаТЗ.Значение);
	    КонецЦикла;		
		//

Возврат ОтчетСтруктура;
КонецФункции

Вывод списка неподдерживаемых элементов данных Zabbix скриптом

Задачу можно решить скриптом на python:

#!/usr/local/bin/python
# coding=utf-8

import socket
import re
from pyzabbix import ZabbixAPI
import time
import requests
requests.packages.urllib3.disable_warnings()

zapi = ZabbixAPI("https://укауц.укаукацук.ru")
zapi.session.verify = False
zapi.login("укацука", "уцкацукацука")


hosts = zapi.host.get();
for hs in hosts:        
    triggers = zapi.item.get(hostids=[hs["hostid"]],);
    for tr in triggers:
        if tr["state"]=="1" and tr["status"]=="0":         
         print hs["hostid"],"|",hs["host"],"|",tr["itemid"].encode('utf8'),"|",tr["name"].encode('utf8');