Архив рубрики: Павел

О понятности кода..

Вот если выбирать как писать код, вот так:

 $url = ($path == '') ? 'javascript:void(0)' : "index.php?content_page=$path";

Или вот так:

if ($path==""){
   $url='javascript:void(0)';
} else {
   $url="index.php?content_page=$path";
};

То я выберу последнее. И меня коробит немножко когда читаю код, написаный в «коротком» стиле. Не роботы же. Может конечно это сила привычки, и со временем, если постоянно писать «сокращенный» код то он становится читаемым «на лету». Но я всё-же за более «человечный» код, чтоб было понятно сразу, без разбора конструкции.

1001-й способ ограничить пользователей 1С

Задача: разрешить пользователям проводить документы только внутри разрешенных им складов.

Частично данная задача успешно решается при помощи RLE и соответствующих ролей. Но! не полностью. Во всяком случае в конфигурации 1С Розница 2.2 нет возможности ограничить пользователя (без изменения конфигураци)…ну например реализовывать  товар с «чужого» склада/Магазина, делать перемещение товаров на «чужие» склады (ограничения работают только для Ордеров???). 

Решение: используем относительно новую фичу от 1С — подписка на события. А именно на событие «Запись». Данные по которым будем проверять можно пользователю записывать данный документ или нет, будем брать из специально созданного справочника.

В котором перечисленна группа к которой принадлежит пользователь, вид документа по которому его ограничиваем и список складов, с которыми ему позволено это документ использовать.

Далее создадим подписку на событие:

И собственно саму обработку события

Функция ПолучитьГруппуПользователя()
 Запрос = Новый Запрос;
  	 Запрос.Текст = "ВЫБРАТЬ
  	                |	ГруппыПользователей.Наименование КАК Наименование
  	                |ИЗ
  	                |	Справочник.ГруппыПользователей КАК ГруппыПользователей
  	                |ГДЕ
  	                |	ГруппыПользователей.Состав.Пользователь.Ссылка = &Ссылка";
	 
	Запрос.УстановитьПараметр("Ссылка",  ПараметрыСеанса.ТекущийПользователь);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	группа="";
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		//сообщить(ВыборкаДетальныеЗаписи.Наименование);
		группа=ВыборкаДетальныеЗаписи.Наименование;
	конеццикла;	           
	возврат группа;
	
КонецФункции	

Функция ПроверкаВсяческихПрав(Источник, Отказ) Экспорт
	отказываем=истина;
	естьправила=ложь;
 	гп=	ПолучитьГруппуПользователя();
	естьОтправитель=ложь;
	естьПолучатель=ложь;
    отказываемОтправитель=истина;
	отказываемПолучатель=истина;
	// проверяем соответствие складам "Откуда"
	 Запрос = Новый Запрос;
  	 Запрос.Текст = 
	 "ВЫБРАТЬ
	 |	ДополнительныеНастройкиПравГрибовСкладыОткуда.Склад.Ссылка КАК СкладСсылка
	 |ИЗ
	 |	Справочник.ДополнительныеНастройкиПравГрибов.РазрешенныеСклады КАК ДополнительныеНастройкиПравГрибовСкладыОткуда
	 |ГДЕ
	 |	ДополнительныеНастройкиПравГрибовСкладыОткуда.Ссылка.ГруппаПользователей.Наименование = &ИмяГруппы
	 |	И ДополнительныеНастройкиПравГрибовСкладыОткуда.Ссылка.ВидДокумента.Наименование = &ИмяДокумента";	 
	Запрос.УстановитьПараметр("ИмяГруппы", гп);
	Запрос.УстановитьПараметр("ИмяДокумента", Источник.Ссылка.Метаданные().Имя);
	РезультатЗапроса = Запрос.Выполнить();	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		естьправила=Истина;		
		если Источник.Ссылка.Метаданные().Реквизиты.Найти("Склад")<>Неопределено тогда			
			если источник.Склад.Ссылка=ВыборкаДетальныеЗаписи.СкладСсылка тогда отказываем=Ложь;
			конецесли;	
		конецесли;
		если Источник.Ссылка.Метаданные().Реквизиты.Найти("СкладОтправитель")<>Неопределено тогда		
			естьОтправитель=Истина;
			если источник.СкладОтправитель.Ссылка=ВыборкаДетальныеЗаписи.СкладСсылка тогда 
				отказываем=Ложь;				
				отказываемОтправитель=Ложь;
			конецесли;	
		конецесли;		
		если Источник.Метаданные().Реквизиты.Найти("СкладПолучатель")<>Неопределено тогда		
			естьПолучатель=Истина;
			если источник.Ссылка.СкладПолучатель.Ссылка=ВыборкаДетальныеЗаписи.СкладСсылка тогда 
				отказываем=Ложь;
				отказываемОтправитель=Ложь;
			конецесли;	
		конецесли;									
	конеццикла;	
 если естьправила=Ложь тогда
	 Отказ=ложь;
 иначе
	  //отрабатываем вариант что два склада отправитель и получатель!
	  если (естьОтправитель=Истина и естьПолучатель=Истина) тогда
		  если отказываемОтправитель=Ложь и отказываемПолучатель=Ложь тогда
		   отказ=ложь;	  
	   иначе
		   отказ=Истина;
		  конецесли;	  
		  иначе
			  отказ=отказываем;			  
	  конецесли
	  
  конецесли;
  
	 если отказ=Истина тогда сообщить("- вы не можете записать данный документ с данными складами - не хватает прав! Обратитесь к Кочанову Сергею.");
	 конецесли;	 	  
  
КонецФункции	

Програмное получение группы пользователя в 1С

Например можно так:

Функция ПолучитьГруппуПользователя()
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ГруппыПользователей.Наименование КАК Наименование
|ИЗ
| Справочник.ГруппыПользователей КАК ГруппыПользователей
|ГДЕ
| ГруппыПользователей.Состав.Пользователь.Ссылка = &amp;Ссылка";

Запрос.УстановитьПараметр("Ссылка", ПараметрыСеанса.ТекущийПользователь);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
группа="";
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
сообщить(ВыборкаДетальныеЗаписи.Наименование);
группа=ВыборкаДетальныеЗаписи.Наименование;
конеццикла;
возврат группа;

КонецФункции

Функция ПроверкаВсяческихПрав(Источник, Отказ) Экспорт

сообщить("-- какойто негодяй из "+ПолучитьГруппуПользователя()+" хочет записать документ! Проверяем а нужно ли?");
КонецФункции

Настройка репликации master-master на MySQL

Шаг 1 на сервере 1

В файл my.cnf добавляем/изменяем следующие строки:

server-id = 1
log_bin = /var/log/mysql/mysql-bin.log
binlog_do_db = radme_rep
bind-address = 10.10.0.1

Перезапускаем mysql, создаем базу (в моем случае это radme_rep)
В консоли выполняем:

SHOW MASTER STATUS;
+------------------+----------+--------------+------------------+
| File | Position | Binlog_Do_DB | Binlog_Ignore_DB |
+------------------+----------+--------------+------------------+
| mysql-bin.000003 | 117 | radme_rep | |
+------------------+----------+--------------+------------------+
1 row in set (0.00 sec)

Создаем пользователя и даем ему права на операции с БД (под ним будет заходить Сервер 2)

create user 'replicator'@'%' identified by 'password';
grant replication slave on *.* to 'replicator'@'%';

Шаг 2 на сервере 2

В файл my.cnf добавляем/изменяем следующие строки:

server-id = 2
log_bin = /var/log/mysql/mysql-bin.log
binlog_do_db = radme_rep
bind-address = 10.10.0.2

Перезапускаем mysql, создаем базу (в моем случае это radme_rep)
В консоли выполняем:

SHOW MASTER STATUS;
+------------------+----------+--------------+------------------+
| File | Position | Binlog_Do_DB | Binlog_Ignore_DB |
+------------------+----------+--------------+------------------+
| mysql-bin.000004 | 107 | radme_rep | |
+------------------+----------+--------------+------------------+
1 row in set (0.00 sec)

Создаем пользователя и даем ему права на операции с БД (под ним будет заходить Сервер 1)

create user 'replicator'@'%' identified by 'password';
grant replication slave on *.* to 'replicator'@'%';

Шаг 3 на сервере 1

В консоли выполняем

slave stop; 
CHANGE MASTER TO MASTER_HOST = '10.10.0.2', MASTER_USER = 'replicator', MASTER_PASSWORD = 'password', MASTER_LOG_FILE = 'mysql-bin.000004', MASTER_LOG_POS = 107; 
slave start;

Шаг 4 на сервере 2

В консоли выполняем

slave stop; 
CHANGE MASTER TO MASTER_HOST = '10.10.0.1', MASTER_USER = 'replicator', MASTER_PASSWORD = 'password', MASTER_LOG_FILE = 'mysql-bin.000003', MASTER_LOG_POS = 117; 
slave start;

Шаг 5

На обоих серверах можно в my.cnf добавить строчку

slave-skip-errors = 1062

Для пропуска ошибок вида Error ‘Duplicate entry…’ в случае одновременной записи в таблицу на обоих серверах (при небольшой нагрузке маловероятно). Иначе — необходимо настроить разный автоинскремент на серверах.

Как удалить репликацию данных?

В консоли на обоих серверах выполняем:

RESET MASTER;
stop slave;
CHANGE MASTER TO "";

 

Далее останавливаем сервер и из папки mysql удаляем все файлы вида

relay-*
*.info

Посмотреть статус репликации можно так:

mysql> SHOW SLAVE STATUS \G;

Поле Seconds_Behind_Master должно стремится к нулю.