1С сортировка структуры

Хотя в синтаксисе обьекта структуры в 1С нет функции сортировки, тем не менее иногда просто необходимо иметь остортированную структуру. Поможет следующая функция:

&НаСервере
Функция сортировкаструктуры(ОтчетСтруктура)
			//сортировка структуры
		ТЗ = Новый ТаблицаЗначений;
	    ТЗ.Колонки.Добавить("Ключ");
	    ТЗ.Колонки.Добавить("Значение");
	    Для каждого элемент из ОтчетСтруктура Цикл
	        новСтрока = ТЗ.Добавить();
	        новСтрока.Ключ = Элемент.Ключ;
	        новСтрока.Значение = Элемент.Значение;
	    КонецЦикла;
	    ТЗ.Сортировать("Значение Убыв");
	    ОтчетСтруктура.Очистить();
	    Для каждого строкаТЗ из ТЗ Цикл
	        ОтчетСтруктура.Вставить(строкаТЗ.Ключ,строкаТЗ.Значение);
	    КонецЦикла;		
		//

Возврат ОтчетСтруктура;
КонецФункции

Вывод списка неподдерживаемых элементов данных Zabbix скриптом

Задачу можно решить скриптом на python:

#!/usr/local/bin/python
# coding=utf-8

import socket
import re
from pyzabbix import ZabbixAPI
import time
import requests
requests.packages.urllib3.disable_warnings()

zapi = ZabbixAPI("https://укауц.укаукацук.ru")
zapi.session.verify = False
zapi.login("укацука", "уцкацукацука")


hosts = zapi.host.get();
for hs in hosts:        
    triggers = zapi.item.get(hostids=[hs["hostid"]],);
    for tr in triggers:
        if tr["state"]=="1" and tr["status"]=="0":         
         print hs["hostid"],"|",hs["host"],"|",tr["itemid"].encode('utf8'),"|",tr["name"].encode('utf8');

Именованный массив в 1С

Ну собственно его нет в 1с. Есть некий «аналог», понятие «Структура».

Инициализируется например вот так:

ОтчетСтруктура=Новый Структура;
ОтчетСтруктура.Вставить("НаТранспорте",0);

Причем ключ не должен содержать пробелов и цифр в начале.

К проинициализированной структуре можно обращаться по ключу например так:

ОтчетСтруктура["НаТранспорте"]=ОтчетСтруктура["НаТранспорте"]+1;

Проверка наличия ключа осуществляется так:

если ОтчетСтруктура.Свойство("ключ") тогда
конецесли

Но я в своей практике, немножко по другому поступил, когда мне была не известна заведомо структура:

&НаСервере
Функция ЗаменитьПробелы(_стр)
	стр=СтрЗаменить(_стр, " ", "_");
Возврат стр;
КонецФункции

// цикл 1, заполняем структуру

		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл				
			если ВыборкаДетальныеЗаписи.Другое<>"" тогда				
				ОтчетСтруктура.Вставить(ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое),0);
			конецесли;	
конеццикла;		


// цикл 2, приращиваем счетчики
		ВыборкаДетальныеЗаписи = Результат.Выбрать();			
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
если ВыборкаДетальныеЗаписи.Другое<>"" тогда							
					ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]=ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]+1;
			конецесли;								
			
		конеццикла;

 

WordPress: перебор записей с сортировкой по дате

Ну например это можно реализовать вот так:

		
 $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;

			$params = array(
				'post_type'         => array('all', 'news'),				
                                'orderby'             => 'date',
				'order'             => 'ACS',
				'paged'             => $paged
			);
		
		$news_var = query_posts($params);

		$new_block = '';
		foreach ($news_var as $new) { setup_postdata($new);

Изменяем функционал документа 1С без изменения конфигурации (Расширением)

В очередной раз понадобилась доработка одного из документов 1С, а именно, чтобы при проведении документа, выводилось некое модальное окно, с вопросами менеджеру который этот документ проводит. А так как я противник какого либо изменения стандартной конфигурации (кушано достаточно с обновлениями) не по делу, то решил попробовать вариант с «расширениями».

Итак, сначала создаем регистр сведений, куда собственно будем заносить информацию которую будет заполнять менеджер. Привязка — к документу реализации:

Далее создадим расширение, через меню Конфигруация — Расширения конфигурации:

Переносим форму документа «Реализация товаров» в раширения:

В появившемся редакторе расширений, видим форму, с не заполненными действиями в командах формы. Если мы попробуем создать действие, выведется вопрос:

, когда вызывать данное действие, ДО, ПОСЛЕ ил ВМЕСТО. В моем случае, я выбрал ДО, и вписал в обработчик следующий код:

&НаКлиенте
Процедура Расш1_ПровестиИзФормыПеред(Команда)
	Структура = Новый Структура("Документ", Объект.Ссылка);
	Массив = Новый Массив;
	Массив.Добавить(Структура);
	Ключ = Новый("РегистрСведенийКлючЗаписи.ДопИнформациОПродажеГрибов", Массив); 
	ПараметрыФормы = Новый Структура("Ключ", Ключ);
	попытка
		ОткрытьФорму("РегистрСведений.ДопИнформациОПродажеГрибов.ФормаЗаписи", ПараметрыФормы);	
	исключение
		Форма = ПолучитьФорму("РегистрСведений.ДопИнформациОПродажеГрибов.ФормаЗаписи");
		Форма.Запись.Документ = Объект.Ссылка;
		Форма.Открыть();	
	конецпопытки
КонецПроцедуры

При нажатии кнопки «Провести» теперь выскакивает окно:

Ну и соответственно пишет в регистр информацию для размышления:

Жизнь замечательных грибов