Архив метки: 1c

Загрузка фото в номенклатуру из прайсов формата XML. 1C Розница 2.2

1) Формат Новотех

Файл XML:

<?xml version="1.0" encoding="UTF-8"?>
<data date="2018-09-26T16:10:20" vendor="SONEX">
<catalog>
<items>
<item id="576ee499-29fc-11e5-8885-003048ffdc82">
<name>370231 NT16 271 хром Встраиваемый декоративный поворотный светильник IP20 GX5.3 50W 12V PEONY</name>
<code>0035856</code>
<article>370231</article>
<description/>
<barcode>4690344039710</barcode>
<item_url>http://isonex.ru/info/index.php?ACTION=FILTER&NAME=370231 NT16 271 хром Встраиваемый декоративный поворотный светильник IP20 GX5.3 50W 12V PEONY</item_url>
-<properties>
<property value="0,193" name="Вес"/>
<property value="0,132" name="Вес нетто"/>
<property value="0,0006" name="Объем"/>
<property value="1" name="Количество ламп"/>
<property value="ВЕНГРИЯ" name="Страна"/>
<property value="NOVOTECH" name="Бренд"/>
<property value="Светильник произведен из сплава цинка. Благодаря сравнительно высоким механическим и литейным качествам, изделия, выполненные из сплава цинка, отличаются высокой точностью деталей декора со сложной конфигурацией. Так же он обладает антикоррозийными свойствами. Декоративные украшения сделаны из хрусталя. Огранка хрусталя, подобно огранке драгоценных камней, позволяет в полной мере проявить свойства, обусловленные большим показателем преломления и дисперсией." name="Описание серии для сайта"/>

<property value="http://isonex.ru/upload/iblock/392/39269950101d067033814dd9e8e3a61b.jpeg" name="Фото на сайте"/>
<property value="хром" name="Цвет плафона"/>

Обработка 1С: Читать далее Загрузка фото в номенклатуру из прайсов формата XML. 1C Розница 2.2

Собственная реализация функционала печати чеков по 54-ФЗ из 1С Розница 2.2

Собственно причиной сподвигнувшей меня на написание данного «велосипеда» послужило то, для того чтобы распечатался полноценный чек из 1С, не используюя РМК, нужно очень много телодвижений от менеджера.  А именно: создать документ реализации, на основании его создать документ «Чек» или «ПКО». Если печатать чек прямо из документа реализации, то в чеке выходят не понятные надписи «Кредит». Читать далее Собственная реализация функционала печати чеков по 54-ФЗ из 1С Розница 2.2

1C 8.3 : нельзя изменять поле содержащее объект данных формы

Ошибка возникает при следующем коде:

&НаСервере
Процедура ПробитьЧекНаСервереГрибов(документ)
ОбщийМодульГрибов.ЗаписатьВБазуMySQLДокумент(документ);	
КонецПроцедуры
&НаКлиенте
Процедура ПробитьЧек(Команда)
	ПробитьЧекНаСервереГрибов(Объект);	     	
КонецПроцедуры

Почему?  Дело в том, что в параметре процедуры ПробитьЧекНаСервереГрибов(Объект) мы передаём данные формы с типом ДанныеФормыКоллекция, и потом на сервере пытаемся их изменить.Даже если эти данные мы не меняем внутри процедуры, 1С на всякий случай ругнется.. Чтобы этого избежать, достаточно изменить код так:

&НаКлиенте
Процедура ПробитьЧек(Команда)	        
	ддк=Объект;
	ПробитьЧекНаСервереГрибов(ддк);	     
КонецПроцедуры

Поиск документа 1С по номеру документа

В некоторых видах документов, которые имеют периодическую нумерацию, например РеализацияТоваровИУслуг, при поиске документа по номеру, нужно указывать дату (период), к которому этот документ относится. Мелочь, а 15 минут потратил, на то чтоб понять почему не возвращает без этого параметра ссылку на документ 😉

	док= Документы.РеализацияТоваров.НайтиПоНомеру("ИП00-008198",ТекущаяДата());
	сообщить(док);

1с и работа в Linux

Попробовал поработать в 1С в конфигураторе и в релизе под Ubuntu 18.4 Давно хотел, да всё собраться не мог. Ну что могу сказать? Сыровато.. Рандомно вылетает конфигуратор с не сохраненной работой. Теряется фокус окон. Иногда не открывается меню. В редакторе конфигуратора иногда курсор становится не видимым. И это спустя сколько лет как работу под Linux озвучили?

Работать конечно можно…. при нужде.