Python. Получение списка IP по hostname

Задача: по извесному доменному имени получить список его IP адресов

Решение:

#!/usr/bin/python
# coding=utf-8
import sys
import socket
import dns.resolver

site = "www.google.com"
dns_server = "8.8.8.81"

try:
    resolver = dns.resolver.Resolver()
    resolver.nameservers = [socket.gethostbyname(dns_server)]
    resolver.timeout = 1
    resolver.lifetime = 1
    answer = resolver.query(site, 'A');
    for rdata in answer :
        print rdata.address
except:
    print "Ошибка получения списка IP";

Смена пароля root в MySQL при физическом доступе к серверу

Если не получается вот так:

mysql> update user set Password=PASSWORD('укацукацу') WHERE User='root';
ERROR 1054 (42S22): Unknown column 'Password' in 'field list'

То можно попробовать вот так:

mysql> update mysql.user set authentication_string=password("wedwe") where user="root";
Query OK, 3 rows affected, 1 warning (0,03 sec)
Rows matched: 3  Changed: 3  Warnings: 1

Резиновый виджет vk

По умолчанию виджет который предлагается vk для установке, не «резиновый». Исправляем:

<div id="vk_widget"></div>
		<script type="text/javascript" src="//vk.com/js/api/openapi.js?116"></script>
		<script>
		    function VK_Widget_Init(){
			document.getElementById('vk_widget').innerHTML = '<div id="vk_groups"></div>';
			VK.Widgets.Group("vk_groups", {mode: 0, width: "auto", height: "400"}, 128460609);
		    };
		    window.addEventListener('load', VK_Widget_Init, false);
		    window.addEventListener('resize', VK_Widget_Init, false);
		</script>	

Управление реле Arduino из 1с

В продолжение вот этого. Если у arduino есть ethernet шиелд, то ей вполне можно управлять даже из 1С. Например Реле питания.

&НаКлиенте
Функция ФункцияВосстановления(Свойство, Значение, ДополнительныеПараметры) Экспорт
   Если Свойство = "ДатаJSON"Тогда
      Возврат ПрочитатьДатуJSON(Значение, ФорматДатыJSON.ISO);
   КонецЕсли;
   Если Свойство = "СтрокаJSON" Тогда
      Возврат СокрЛП(Значение);
   КонецЕсли;
   Если Свойство = "uidJSON" Тогда
      Возврат Новый УникальныйИдентификатор(Значение);
   КонецЕсли;
КонецФункции

&НаКлиенте
Процедура СчитатьСтатус(Команда)
		файл=новый чтениетекста("http://"+этаформа.Объект.ИП+"/");
		фф=файл.Прочитать();
		файл.Закрыть();
		фф=стрзаменить(фф,"<!DOCTYPE HTML>","");
		тЧтение=Новый ЧтениеJson;
		тЧтение.УстановитьСтроку(фф);
		тДанные = ПрочитатьJSON(тЧтение, Ложь, , , "ФункцияВосстановления", ЭтотОбъект);
		пинсстат=тДанные.pinsstatus;			
		к=0;
		для каждого стат из пинсстат цикл			
			к=к+1;
			если к=1 и стат=1 тогда этаформа.Объект.Реле1=Истина иначе этаформа.Объект.Реле1=ложь;конецесли;
			если к=2 и стат=1 тогда этаформа.Объект.Реле2=Истина иначе этаформа.Объект.Реле3=ложь;конецесли;
			если к=3 и стат=1 тогда этаформа.Объект.Реле3=Истина иначе этаформа.Объект.Реле4=ложь;конецесли;
			если к=4 и стат=1 тогда этаформа.Объект.Реле4=Истина иначе этаформа.Объект.Реле4=ложь;конецесли;
		конеццикла;		
   		тЧтение.Закрыть(); 		
		этаформа.Объект.жсон=фф;

КонецПроцедуры

&НаКлиенте
Процедура СчитатьСтатус(Команда)
		файл=новый чтениетекста("http://"+этаформа.Объект.ИП+"/");
		фф=файл.Прочитать();
		файл.Закрыть();
		фф=стрзаменить(фф,"<!DOCTYPE HTML>","");
		тЧтение=Новый ЧтениеJson;
		тЧтение.УстановитьСтроку(фф);
		тДанные = ПрочитатьJSON(тЧтение, Ложь, , , "ФункцияВосстановления", ЭтотОбъект);
		пинсстат=тДанные.pinsstatus;			
		к=0;
		для каждого стат из пинсстат цикл			
			к=к+1;
			если к=1 и стат=1 тогда этаформа.Объект.Реле1=Истина иначе этаформа.Объект.Реле1=ложь;конецесли;
			если к=2 и стат=1 тогда этаформа.Объект.Реле2=Истина иначе этаформа.Объект.Реле3=ложь;конецесли;
			если к=3 и стат=1 тогда этаформа.Объект.Реле3=Истина иначе этаформа.Объект.Реле4=ложь;конецесли;
			если к=4 и стат=1 тогда этаформа.Объект.Реле4=Истина иначе этаформа.Объект.Реле4=ложь;конецесли;
		конеццикла;		
   		тЧтение.Закрыть(); 		
		этаформа.Объект.жсон=фф;

КонецПроцедуры