Архив рубрики: 1C

Разработки на платформе 1С

Доступ к процедурам и функциям общего модуля объекта из формы списка.

Странное желание, однако бывает.. Что делаем:

  1. Получаем обьект документа
  2. Обращаемся к процедуре/функции этого обьекта

Например:

док=Документы.СК_ГР_ОграничениеПотребителямСМС.НайтиПоНомеру(НомерДокументаДляПроверки).ПолучитьОбъект();		
док.НекаяПроцедураВМодуле();

Пауза в исполнении кода в 1С

В языке 1С нет команды паузы. Ну нет и всё тут! Парадигма: если чего то нет, что вам нужно, значит вы что то делаете не так (с) конечно хороша… Но усложнять код ради «выверта»? Код должен быть читаем и прост! Ну вот как например ПРОСТО сделать 10 попыток чтения чего-то с паузой в 60 секунд например не городя огород из костылей? Например, элементарная схема:

	    
  Для Сч = 1 По 10 Цикл
       рез=ПопытатьсяЧтоТоСделать();           
	если рез=Ложь тогда
	 ГлПауза(1);
	иначе	
	    Прервать;
	конецесли				
 конеццикла

А вот так можно реализовать функцию ГлПауза:

 Процедура глПауза(Сек)
scr = Новый COMОбъект("WScript.Shell");
scr.Run("sleep "+СокрЛП(Число(Сек)),0,1);
КонецПроцедуры;

Вариант 2 с загрузкой процессора:

Процедура глПауза(Сек)
	КонДата = ТекущаяДата() + Сек;
  	Пока ТекущаяДата() < КонДата Цикл
      // ждемссс....
  	КонецЦикла;	
КонецПроцедуры

1С: Не работает авторизация по учетной записи

Ситуация: есть два сервера Windows, один из которых играет роль сервера 1С предприятие+БД, другой RDP.  Оба сервера «отдельно стоящие», не входят в AD. Проблема заключается в не возможности входа по учетной записи на RDP сервере, т.к. запущенный клиент 1С на сервере RDP ищет на самом деле у.з. на сервере 1С предприятие.

Решение: создавать ПОЛНОСТЬЮ идентичные учетные записи пользователей на обоих серверах. Вплоть до одинакового пароля. Тогда фишка с авторизацией «прокатывает»

1С: получить ссылку по уникальному идентификатору

Задача:  есть некий идентификатор 09e5174f-551f-11e8-a22b-0800272d9f13. Нужно по нему получить ссылку на элемент справочника.

Решение:

Номенклатура = Справочники.Номенклатура.ПолучитьСсылку(Новый УникальныйИдентификатор("09e5174f-551f-11e8-a22b-0800272d9f13"))

1C: метод объекта не обнаружен ПолучитьНомерНаПечать

После очередного обновления конфигурации 1С, бухгалтерия обнаружила что не работает один из отчетов. Выдает ошибку

метод объекта не обнаружен ПолучитьНомерНаПечать

Проблема известная и легко гуглится — дело в обновлении БСП в конфигурации. Разработчики переименовали функцию ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать() на ПрефиксацияОбъектовКлиентСервер.НомерНаПечать()