Все записи автора Павел Грибов

Пауза в исполнении кода в 1С

В языке 1С нет команды паузы. Ну нет и всё тут! Парадигма: если чего то нет, что вам нужно, значит вы что то делаете не так (с) конечно хороша… Но усложнять код ради «выверта»? Код должен быть читаем и прост! Ну вот как например ПРОСТО сделать 10 попыток чтения чего-то с паузой в 60 секунд например не городя огород из костылей? Например, элементарная схема:

	    
  Для Сч = 1 По 10 Цикл
       рез=ПопытатьсяЧтоТоСделать();           
	если рез=Ложь тогда
	 ГлПауза(1);
	иначе	
	    Прервать;
	конецесли				
 конеццикла

А вот так можно реализовать функцию ГлПауза:

 Процедура глПауза(Сек)
scr = Новый COMОбъект("WScript.Shell");
scr.Run("sleep "+СокрЛП(Число(Сек)),0,1);
КонецПроцедуры;

Вариант 2 с загрузкой процессора:

Процедура глПауза(Сек)
	КонДата = ТекущаяДата() + Сек;
  	Пока ТекущаяДата() < КонДата Цикл
      // ждемссс....
  	КонецЦикла;	
КонецПроцедуры

1С: Не работает авторизация по учетной записи

Ситуация: есть два сервера Windows, один из которых играет роль сервера 1С предприятие+БД, другой RDP.  Оба сервера «отдельно стоящие», не входят в AD. Проблема заключается в не возможности входа по учетной записи на RDP сервере, т.к. запущенный клиент 1С на сервере RDP ищет на самом деле у.з. на сервере 1С предприятие.

Решение: создавать ПОЛНОСТЬЮ идентичные учетные записи пользователей на обоих серверах. Вплоть до одинакового пароля. Тогда фишка с авторизацией «прокатывает»

Опять жадный Мегафон морочит людям голову..

На даче у меня 4G интернет от Мегафона. Сегодня заметил, что при при попытке перехода на страницу заблокированную Роскомнадзором, Мегафон стал перебрасывать на страницы, сверстанные специально с таким текстом,  что человек не знакомый с уловками данного ОПСОСа прочитает и подпишется на  подписки сам того не желая.. А потом опять ходи и доказывай что ты не «осел».

Заметили? Кнопка «Подробнее» не только описание, но и одновременно и согласие на подписку.

Кто больше мудит с платными подписками из мобильных операторов?

View Results

Загрузка ... Загрузка ...

1С: получить ссылку по уникальному идентификатору

Задача:  есть некий идентификатор 09e5174f-551f-11e8-a22b-0800272d9f13. Нужно по нему получить ссылку на элемент справочника.

Решение:

Номенклатура = Справочники.Номенклатура.ПолучитьСсылку(Новый УникальныйИдентификатор("09e5174f-551f-11e8-a22b-0800272d9f13"))