Все записи автора Павел Грибов

Сохранение части данных баз данных MSSQL

Задача: выгрузить в виде SQL запросов часть данных из баз MSSQL

Решение: используем стандартную оболочку Microsoft SQL Server Management Studio.

1) Правой кнопкой мыши щелкаем по БД, выбираем «Задачи -> Сгенерировать скрипт» (Task -> Generate Script)

2) В открывшемся «мастере» выберите таблицы которые хотите сохранить в виде SQL

В следующем шаге, сохраните запрос в файл

Диалоговое окно в 1С

Можно реализовать стандартным способом, что-то типа:

&НаКлиенте
Процедура ВыключитьИнтернет(Команда)
	Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса",ЭтотОбъект);	
	ПоказатьВопрос(Оповещение,
        "Вы убеждены что хотите отключить несчастного контрагента?",
        РежимДиалогаВопрос.ДаНет,
        0, // таймаут в секундах
        КодВозвратаДиалога.нет, // (необ.) кнопка по умолчанию
        "Хороший вопрос" // (необ.) заголовок
    );    
КонецПроцедуры
&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат,Параметры)  Экспорт
	если Результат=КодВозвратаДиалога.Да тогда
		сообщить("--жаль..");
	иначе
		сообщить("");
	конецесли;	
КонецПроцедуры

Передача параметров при создании Формы.

Задача: по нажатии кнопки, открыть форму обработки с заполненным реквизитом ИНН.

Собственно вот классический способ:  по нажатию кнопки выполняем код:

&НаКлиенте
Процедура Расш1_ДействияБиллингаПосле(Команда)
	ПП = Новый Структура("ИНН", "100");
	Форма=ПолучитьФорму("Обработка.ДействияLanBilling.Форма.Форма",ПП);
	Форма.Открыть() 	
КонецПроцедуры

Далее обрабатываем параметр в самой форме, в процедуре ПриСозданииНаСервере:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Если Параметры.Свойство("ИНН") Тогда
        объект.ИНН=Параметры["ИНН"];
    КонецЕсли;	
КонецПроцедуры

Поступление в сталкеры

ААААА!!!!!!! КАЖЕТСЯ ТУТ ЕСТЬ МОНСТРЫ!!! Рроооооооооооооооооооооооо!! Она орала роооооо! Я не понимал что делать, но перед этим я раскажу как это началось.

Я проснулся в больнице. Я только встал с койки как за мной вдруг подъехала машина. Меня взяли дядки с пулемётами. После рассказа я понял, что я выживший в зомби апокалипсисе. Но вдруг машина на которой я ехал упала в кювет и все люди сдохли. После этого переполоха мужчина подошел ко мне, потрогал меня и сквозь зубы сказал: Чтоб тебя — он живой! Потом я незаметно уснул и меня куда то отвезли. Кто-то сказал — «Это чё за труп? Да чтоб меня зона сожрала если он мёртв.»

Через некоторое время я очухался. Ко мне подошёл старый толстый дед и сказал: «Ну чё салага, добро пожаловать в Маналит. Твоё первое задание — расчистистить городок от зомби. Живо беги к волку»

  Ядолго искал волка и всёже  его нашёл. А он  и говорит: «Ох чёт колбаса вся радиоактивщина».  Дал автомат и говорит:  «Дуй давай я тебе ещё новичков подсуну, а вы как нибудь без меня обойдётсь».

Пошли мы неумехи блин и набрели на какой-то артефакт.  Думаем, думаем а потом плюнули и пошли. Я спросил:  «Чё у них из оружия?»  Они все достали по ножу и сказали: «Это всё» . «Ох ох ох» Ну окей мы поискали коробки и нашли всем по пистолету. Хз откуда они там. В общем шли мы, шли да на стадо зомби набрели. Ох туго нам пришлось, кое как отбились. Нас была трое, а стало двое. В общем тот чувак отошёл сделать дела и зомби не долго думая съели его. Пришли мы к Волку, расказали о Патере и он расстроился. Обматюгал нас и дал две копейки. Сказал: «Отлежитесь уроды». На следуйши день продолжения команндной работы законилось.

Атол 55Ф + терминал эквайринга VeriFone 802, ошибка 4321

При проведении эквайринговой операции 1С Розница 2.2 выводит ошибку:

При выполнении операции возникла ошибка:
«Ошибка отмены операции транзакции. Обратитесь в банк. Ошибка при выполнении функции АварийнаяОтменаОперации, ответ терминала — Ошибка 4321».
Оплата по карте не была произведена.

1) Тест драйверов кассы ККМ проходит
2) Тест драйверов терминала проходит
2) SBRFCOM.dll зарегистрирована regsvr на 7 параметров (пробовал и на 3)

Ошибка происходит только при выводе чека экваринговой операции на ККМ. Деньги с карточки снимаются.

Решение: заработало когда переставили терминал в порт USB3.0 (синенький). Возможно и правда не хватало питания, а может быть особенность реализации конкретно на этой материнской плате. Т.к. на других ПК всё работало в любых портах.