Все записи автора Павел Грибов

Собственная реализация функционала печати чеков по 54-ФЗ из 1С Розница 2.2

Собственно причиной сподвигнувшей меня на написание данного «велосипеда» послужило то, для того чтобы распечатался полноценный чек из 1С, не используюя РМК, нужно очень много телодвижений от менеджера.  А именно: создать документ реализации, на основании его создать документ «Чек» или «ПКО». Если печатать чек прямо из документа реализации, то в чеке выходят не понятные надписи «Кредит». Читать далее Собственная реализация функционала печати чеков по 54-ФЗ из 1С Розница 2.2

1C 8.3 : нельзя изменять поле содержащее объект данных формы

Ошибка возникает при следующем коде:

&НаСервере
Процедура ПробитьЧекНаСервереГрибов(документ)
ОбщийМодульГрибов.ЗаписатьВБазуMySQLДокумент(документ);	
КонецПроцедуры
&НаКлиенте
Процедура ПробитьЧек(Команда)
	ПробитьЧекНаСервереГрибов(Объект);	     	
КонецПроцедуры

Почему?  Дело в том, что в параметре процедуры ПробитьЧекНаСервереГрибов(Объект) мы передаём данные формы с типом ДанныеФормыКоллекция, и потом на сервере пытаемся их изменить.Даже если эти данные мы не меняем внутри процедуры, 1С на всякий случай ругнется.. Чтобы этого избежать, достаточно изменить код так:

&НаКлиенте
Процедура ПробитьЧек(Команда)	        
	ддк=Объект;
	ПробитьЧекНаСервереГрибов(ддк);	     
КонецПроцедуры

Поиск документа 1С по номеру документа

В некоторых видах документов, которые имеют периодическую нумерацию, например РеализацияТоваровИУслуг, при поиске документа по номеру, нужно указывать дату (период), к которому этот документ относится. Мелочь, а 15 минут потратил, на то чтоб понять почему не возвращает без этого параметра ссылку на документ 😉

	док= Документы.РеализацияТоваров.НайтиПоНомеру("ИП00-008198",ТекущаяДата());
	сообщить(док);