Архив метки: структура

1С сортировка структуры

Хотя в синтаксисе обьекта структуры в 1С нет функции сортировки, тем не менее иногда просто необходимо иметь остортированную структуру. Поможет следующая функция:

&НаСервере
Функция сортировкаструктуры(ОтчетСтруктура)
			//сортировка структуры
		ТЗ = Новый ТаблицаЗначений;
	    ТЗ.Колонки.Добавить("Ключ");
	    ТЗ.Колонки.Добавить("Значение");
	    Для каждого элемент из ОтчетСтруктура Цикл
	        новСтрока = ТЗ.Добавить();
	        новСтрока.Ключ = Элемент.Ключ;
	        новСтрока.Значение = Элемент.Значение;
	    КонецЦикла;
	    ТЗ.Сортировать("Значение Убыв");
	    ОтчетСтруктура.Очистить();
	    Для каждого строкаТЗ из ТЗ Цикл
	        ОтчетСтруктура.Вставить(строкаТЗ.Ключ,строкаТЗ.Значение);
	    КонецЦикла;		
		//

Возврат ОтчетСтруктура;
КонецФункции

Именованный массив в 1С

Ну собственно его нет в 1с. Есть некий «аналог», понятие «Структура».

Инициализируется например вот так:

ОтчетСтруктура=Новый Структура;
ОтчетСтруктура.Вставить("НаТранспорте",0);

Причем ключ не должен содержать пробелов и цифр в начале.

К проинициализированной структуре можно обращаться по ключу например так:

ОтчетСтруктура["НаТранспорте"]=ОтчетСтруктура["НаТранспорте"]+1;

Проверка наличия ключа осуществляется так:

если ОтчетСтруктура.Свойство("ключ") тогда
конецесли

Но я в своей практике, немножко по другому поступил, когда мне была не известна заведомо структура:

&НаСервере
Функция ЗаменитьПробелы(_стр)
	стр=СтрЗаменить(_стр, " ", "_");
Возврат стр;
КонецФункции

// цикл 1, заполняем структуру

		ВыборкаДетальныеЗаписи = Результат.Выбрать();
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл				
			если ВыборкаДетальныеЗаписи.Другое<>"" тогда				
				ОтчетСтруктура.Вставить(ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое),0);
			конецесли;	
конеццикла;		


// цикл 2, приращиваем счетчики
		ВыборкаДетальныеЗаписи = Результат.Выбрать();			
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
если ВыборкаДетальныеЗаписи.Другое<>"" тогда							
					ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]=ОтчетСтруктура[ЗаменитьПробелы(ВыборкаДетальныеЗаписи.Другое)]+1;
			конецесли;								
			
		конеццикла;